Replacing a Hall Sensor

Hall effect sensors sometimes fail, but are easy enough to fix

Taking the hub motor apart and replacing a hall sensor might sound like a pretty daunting task, but it’s really not that difficult. The first thing you need to do is get hold of a suitable, replacement SS41 hall-effect sensor. One can usually be found on ebay here, or from RS components (but with a pretty steep postage price) here.

Next you remove the stator (the hub motor section of the rear wheel) from the rear wheel itself (see blog entry) so that you can get at the motor’s inner workings. This done, the hall sensors and wiring are exposed and ready to work on.

The sensors are held in little shaped grooves in the metal treads on one side of the stator’s perimeter. Now you need to identify which sensor holds the wire that you detected a fault on. Each sensor has three wires, – two of them are the 4.5V live (red) and GND (black) which serve the sensor, the third is the hall sensor wire which returns a signal to the controller based on its rotational position in the hub motor casing. The third wire for each hall sensor is yellow, green and blue respectively, as shown below.

In my case, it was the yellow wire that was showing no signal, and this one goes to the middle hall sensor on my stator.

The component itself is held in with a bit of epoxy resin and sometimes has bits of silicone sealant gummed about. The epoxy can be softened by warming it a little with the flame from a cigarette lighter.

A gentle tap with a hammer and screwdriver knocks it loose with ease.

Note how one side of the hall effect sensor has bevelled corners. This side faces outwards (on my motor, at least) and is designed so that it can only fit in its socket the right way round. This is important, as it makes it hard to accidentally reverse the wiring sequence.

Here’s the replacement sensor in situ.

You can more clearly here how it fits with the bevelled corners facing outwards.

Next it’s a simple case of soldering the new sensor in. Snip the head of the old sensor off, strip the hall sensor wires, and desolder the legs from the old one, then solder on the legs of the replacement sensor. Don’t forget to put fresh sections of heatshrink on the wires, and push them way up the wires where the soldering iron won’t prematurely shrink them. Then pull the heatshrink down into place over the soldered legs, like with their neighbours.

This done, it’s a case of fitting the sensor back into its socket. Use a little blob of epoxy resin to hold it firmly in place.

All done! Finally, carefully refit the stator to the rear wheel and test the wiring from the hall connector. If you did everything right, then you should once more have a working hub motor.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s